Renault Forums :: Independent Renault forum - View Single Post - Removing Cabasse Amplifier from Boot Space of Estate

View Single Post
post #6 of (permalink) Old 21st January 2008 Thread Starter
McBish's Avatar
Join Date: Jan 2008
Posts: 55
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 2 Posts

Managed to sit toddler in front of loooong video (bad parenting, I know!) and went outside determined to do the job. Managed to lift the Cabasse amp (the wiring loom to it is just so conveniently a couple of inches shorter than I really felt comfortable with, but got away without yanking any wires off). Installed the ISO stub cables and somehow managed to get the amp back and locked in (that was one of the more tricky parts to feed all the wiring in without getting in the way). I then pulled apart the nearside plastic trims to feed an extender cable to the Parrot control box (which I've put under the heater box in the centre console). Lost yet more skin off my knuckles but managed to route the cable such that it's pretty well disguised for the length of its run.

Checked that the system works (which it does - haven't yet tested it in anger on a motorway run) and then put all the trim back, which was one of the trickier parts of the job. One or 2 clips haven't fully re-engaged and the rear N/S belt is a bit lazy about retracting - suspect that it's catching on the trim. Need to go back and sort that out before the MOT in Mar!

Thanks to all for suggestions and giving me the confidence to go for it! First impressions are that it was worth the effort - it probably took me a couple of hours active working time (having stopped for lunch half way through and change DVDs for the toddler ).
Currently in McBish's garage:
03 Laguna II 1.9dCi Initiale Estate

Last edited by McBish; 21st January 2008 at 07:27 AM.
McBish is offline  
For the best viewing experience please update your browser to Google Chrome