Renault Forums :: Independent Renault forum - View Single Post - Renault Clio - Engine Management Light On

View Single Post
post #20 of (permalink) Old 21st January 2008
Junior Member
Join Date: Jan 2008
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for that Dockwood. There seems to be number of possible things that could be causing the fault so it would be good to hear from anyone who has managed to solve it. The guy who normally does the service work on mine got the ECU read and it apparently produced a long list of fault codes. However after clearing the memory, it took over a week for the fault to re-occur. In the meantime he had shown the fault codes to a friend of his at the local Renault main dealer who instantly said it was the wiring loom (a common fault apparently) and that it would require a new loom and a software upgrade. Total cost would be around 300. I've also heard that the metal cover over the ECU can damage the wiring going into the ECU and on close inspection there did appear to be some damage although no bare wires. I tried stopping the metal cover from rattling about with some Blue Tack and all seemed well until this Saturday when the idle fault occured again after a short run so it's back to the drawing board. It may be coincidence but whereas the fault got to the stage where it was happening every time the car was driven, since the ECU fault codes were read it now only happens once in a while.
Currently in bagpuss27's garage:
Renault Clio Dynamique
bagpuss27 is offline  
For the best viewing experience please update your browser to Google Chrome