Renault Forums :: Independent Renault forum - View Single Post - Laguna II electrical problem

View Single Post
post #1 of (permalink) Old 30th January 2008 Thread Starter
Junior Member
Join Date: Sep 2007
Posts: 21
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to moomoomoo
Laguna II electrical problem

Here's a new one for you guys!

My 2001 Laguna has developed a strange problem.. All to do with the ignition. Basically the stereo no longer works in accordance with the key, and the clock display doesn't light up when the key is inserted like normal. I tested the ignition wire on the ISO block and indeed, no voltage when key is in.

Just to confirm this was the problem with both the clock and stereo, I shorted the permenant live wire on the ISO block to the ignition controled wire and indeed the clock display lit up with the time. So a temporary fix would be to run a wire from the arm box cigarette ligher (which is also ignition controlled and is _still working_) and connect it to the acc wire on the iso block which would fix the stereo and clock.

One thing to note is that when I apply 12v to the wire, a relay clicks in the glove box. Further investigation revealed 3 fuses there as well, but they're all fine. Also checked fuse in ash tray.

Any ideas guys?
Currently in moomoomoo's garage:
2001 Renault Laguna II 1.8 Privilege
moomoomoo is offline  
  5 Lastest Threads by moomoomoo
Thread Forum Last Poster Replies Views Last Post
Laguna II electrical problem Electronics Gogslad 11 1653 30th January 2008 02:32 PM
Alarm problem Electronics moomoomoo 6 1404 30th September 2007 03:00 PM
For the best viewing experience please update your browser to Google Chrome