Renault Forums :: Independent Renault forum - View Single Post - Renault Espace - Running Cold,Poor Heater*FIXED*

View Single Post
post #11 of (permalink) Old 31st January 2008
Join Date: Jan 2008
Posts: 35
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by flash-dj View Post
just a information update everyone was right about it being 4 bars i replaced the thermostat today and blead the system replacing coolant/antifreeze my car is now running warmer indicating 4 bars on the temp gauge and is toasty warm thanks for the info guys i did have poor heating in the car and i still suspect there is air in the system
i think renault made a right mess with the design of the heating system ie only having 1 bleed nipple on the pipes however i am going to try a new method of bleeding the system using a piece of tube to said bleed nipple and connecting it to the expansion tank and taking it for a drive with the hope that while driving the air will get forced out but without loosing water in the process
I have just got an Espace and found that I have no heat! Car runs fine with 3 bars on the temp gauge even in very heavy traffic.

Got a new thermostat to fit but after a quick look under the bonnet where does it go, which pipes did you remove to flush the system. As you have recently done the job any help would be very much appreciated especially as they are forecasting snow.
Currently in bigandyd's garage:
Renault Laguna Privilege DCI
bigandyd is offline  
For the best viewing experience please update your browser to Google Chrome