The Vel Satis Club, for all things Vel.... - Page 82 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #406 of 428 (permalink) Old 22nd November 2009
Diamond member
Wile7's Avatar
Join Date: Oct 2009
Posts: 157
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 1
Thanked 1 Time in 1 Post
Well done on the battery issue Lee (hopefully sorting it I mean). Useful info to know.

Velsatistony - hopefully not a serious issue for you.....fingers crossed.

Currently in Wile7's garage:
2002 3.5 Initiale Vel Satis, 1996 Caterham 1700 Supersprint, 95 Merc W124 E200 estate, 2007 Suzuki Swift, 1995 Mercedes Sprinter 412, Aprilia Moto Starck 6.5
Wile7 is offline  
Sponsored Links
post #407 of 428 (permalink) Old 23rd November 2009
Diamond member
hu88ertvelsat's Avatar
Join Date: Jan 2009
Posts: 457
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 2 Posts
Originally Posted by velsatistony View Post
hi, my 3dv6 auto has being running great for the last few months but over the last few days it has developed a worrying fault.
I cant get it above 2800 revs without a struggle which means overtaking and high speed driving are impossible.
it pulls well to 2500 then just shudders, no warning lights etc, i need the car daily and and dont know where to start, could it be a fuel issue, coils, turbo, etc etc
any advice much appreciated,

also, heating doesnt work that well, i need it to be set to max temperature (26) to get heat, anything less than that is mildly warm, demisting isnt great either. is it just needing a recharge with gas or is it a sensor?

furthermore, rain sensor playing up too, even in light drizzle, wipes on all the time with no intermittent wiping

Hi Tony,

Just to say I'm having the same problems with me heater which only blows hot air when set to max @ 26 degrees, which then makes the car way too hot and stuffy.

So I'll keep you posted if I get any good advice or once I've got someone to take a look at it.

Good luck with your other issues too!

hu88ertvelsat is offline  
post #408 of 428 (permalink) Old 23rd November 2009
Junior Member
velsatistony's Avatar
Join Date: Jun 2009
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
hi all,
update on the problems i'm having with the VS
the problem i have had with revving above 2800 has got worse, it now sometimes wont rev at all when I press the pedal, idle feels a bit 'lumpy' too.
becoming an imtermittent problem now, doesnt feel so bad when the car is started first thing in the morning,
I drove 75 miles this morning (motorway) and didnt really notice the fault until near the end of the journey but yesterday, the fault developed within 3 miles of starting up.
Anyone in East Scotland with a code reader? I am hoping plugging in will give me a fault code.
I am still under warranty (well sort of!, I have passed the mileage service was due) but would rather check the diagnostics first to see if its an easy fix
Currently in velsatistony's garage:
velsatis 3.0dci initiale, Ssangyong Rodius
velsatistony is offline  
post #409 of 428 (permalink) Old 23rd November 2009
Platinum member
saabguy's Avatar
Join Date: Dec 2007
Posts: 1,528
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 4
Thanks: 5
Thanked 133 Times in 115 Posts
Originally Posted by Lee_Marshall View Post
I had a similar problem with a SAAB 9000 a few years ago. After the dealer changed the coils, turbo, ECU and various other parts (all under warranty, 3000 + labour) it turned out to be the HT leads. Total cost 65.
Hmmm, only problem is a Saab 9000 doesn't have HT leads it has a direct ignition cassette, so something not quite right there.

I can recommend Brew Garages in Wimbledon, he's a Renault Specialist and did all the work on my Satis whilst i had it.
Currently in saabguy's garage:
2002 Citroen C5 SX 2.2 HDi
saabguy is offline  
post #410 of 428 (permalink) Old 23rd November 2009
Posts: n/a

Please note that the Vel Satis now has it's own dedicated section:

Closed Thread

club , satis , things , thread , vel , velsatis , veltemp

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome