Renault Forums :: Independent Renault forum - View Single Post - Electrical problems

View Single Post
post #2 of (permalink) Old 2nd February 2008
Junior Member
Join Date: Oct 2007
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

Originally Posted by balithbe View Post
Hello,about 2 weeks ago I was sat in my Scenic 1.9dci 2002 waiting for her indoors I decided to sound the horn to try to hurry her up,the ignition was off,no keys in ignition & when I pressed the horn all I got was smoke from underneath the airbag centre of steering wheel& no sound from the horn,I removed airbag & found the wiring for the 3 horn push contacts had melted & burned out.I obtained another peice of loom & fitted it but horn does not work,fuze is ok,removed and tested horn its ok,can`t understand why it should melt the horn push wiring as I think it is just the earth to the horn.
Today I noticed when I started the engine & drove off I had no heater blower on any of the 4 speeds,after about 2 minutes driving they started working in all speeds.Stopped car left for about 1 hour then same thing hapened.Works fine once it`s started working.
Don`t know if these 2 can be connected.
Any help please.

Hummm... sounds like what just happened to my wifes 2002 1.9dci. The other day the horn started sounding randomly when turning the steering wheel so I took the fuse out (good solution )

Yesterday there was a smell of burning in the car coming from the steering wheel. I took the plastic casing off the coloum today and found that the black plastic ring immediately behind the steering wheel appears to have got very hot, I think this could be the airbag switch?

Did you ever managed to fix your problem?
Has anyone got any suggestions about my problem?

edthedead is offline  
For the best viewing experience please update your browser to Google Chrome