Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II - Phase 1 - Electronics - Idle problems and possible fix - Motorised Throttle Valve

View Single Post
post #6 of (permalink) Old 10th March 2006 Thread Starter
Join Date: Nov 2005
Posts: 57
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Laguna II Owner
The car will go into limp home mode if it thinks their is a problem ( limits engine revs to 2k ). Definitely was not limp home mode, it was fine if I kept going, which I managed to do, by going home via a section of the M6, so got upto 70mph, it was only on issue on depressing the clutch.

Will also do funny things if the accelerator potentiometers are faulty. Have them checked by Renault Dealership as this could be a potentially serious and dangerous fault. Will do.

Another thing to do is have someone qualified look or clean your throttle body . I been wanting to do mine for a while as my car will sometimes struggle on idle if all the electrics are on ( normal idle is 800rpm but will dip to 700 in this case )..I think this could be my problem, its booked into renault so I will suggest this to them, i hope they do not just re-set the engine managment, as this may help short term, but it will come back.

Also of course check the obvious ( like sticking pedal due to carpet mats )

I can send you some details of the pedal assembly if you like - pm me..
Thanks for your reply.

Hann666 is offline  
For the best viewing experience please update your browser to Google Chrome