Renault Forums :: Independent Renault forum - View Single Post - Problems fitting car stereo

View Single Post
post #1 of (permalink) Old 9th February 2008 Thread Starter
Join Date: Feb 2008
Posts: 67
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 33
Thanked 2 Times in 2 Posts
Problems fitting car stereo


I've got a 2001 renault clio which when it came back from the garage recently needed it's security code entering, which I don't have, so thought that rather than paying the 20 the renault dealership wanted for the code, I would just buy a cheap head-unit to replace it with.

When the replacement arrived I tried installing it but it wouldn't power up. I connected the two ISO connectors but not the aerial as it looks like i'll need an adapter for that. As it wouldn't power up and because it had been quite badly damaged in transit, I presumed it was broken and ended up ordering a different cd player as a replacement.

Last week the second CD player arrived and I had the exact same problem - nothing happens when I press the on button. Again it's got the two ISO connectors plugged in (as firmly as they'll go), but not the aerial. Nor have I plugged in what I assume to be a proprietary cable for my steering wheel controls as there's no where for it to plug in.

My initial thought was that the ISO connectors weren't plugged in properly but they're in as firmly as they'll go. I plugged the old Renault stereo back in and that still powers up.

So, I thought that maybe the problem was that it wouldn't turn on unless the aerial was in so I got an adapter, and tried them both again but it made no difference!

It seems unlikely that both players I've had are faulty, so does anyone have any ideas what the likely problem is??

I looked at the ISO connector's coming from the car and the ones on the stereos and they don't match at all! different numbers of cables and all different colours!

The stereos both have diagrams of what each wire does, but I can't find anything documenting what wire does what on the car's connector. Anyone any ideas?


Currently in Pea's garage:
2001 Clio II Authentique 1.2, 2006 Scenic II 1.6
Pea is offline  
  5 Lastest Threads by Pea
Thread Forum Last Poster Replies Views Last Post
Fitting roof box to MKIV Espace Bodywork Pea 6 543 10th December 2015 09:18 PM
Steering wheel audio control adapters Electronics Pea 0 211 1st December 2015 03:50 PM
How long to charge Clio battery from dead? Electronics madnoel10 9 2529 18th May 2014 01:34 PM
2006 Scenic Battery Warning Electronics BLACK ESPACE 8 1402 23rd March 2014 11:05 AM
Scenic II lights issue - bulbs fine, multiple... Electronics lancs dave 3 1219 22nd November 2013 02:45 PM
For the best viewing experience please update your browser to Google Chrome