Renault Forums :: Independent Renault forum - View Single Post - 98 Megane Speedomoter dropping to Zero

View Single Post
post #1 of (permalink) Old 13th March 2006 Thread Starter
Junior Member
Join Date: Nov 2005
Posts: 11
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
98 Megane Speedomoter dropping to Zero


My 98 Megane is experiencing problems with the speedometer. A couple of months ago, I noticed the needle would suddenly drop to 0, then go straight back up. This happened at various speeds. Recently, it's doing it more often, and now sometimes drops to 0 for long periods of time (up to a couple of minutes) before coming back.

It also stops the odometer ticking up when the speedometer drops to 0, which says to me it's a problem at the engine/gearbox end, rather than at the instrument end.

I checked the Haynes manual, and it says I need to drop the gearbox to replace the cable. Can anyone confirm that this is the only way to replace the cable? Seems a bit extreme, and well out of my league!

Thanks, Steve
Currently in stevenh1978's garage:
'03 Ford Mondeo now, as his '98 Megane 1.9 Dti RXE was getting too expensive to fix!!
stevenh1978 is offline  
  5 Lastest Threads by stevenh1978
Thread Forum Last Poster Replies Views Last Post
1998 Megane erratic speedo Electronics swfcowl5 3 2067 4th November 2006 05:10 PM
Rear Nearside Light Cluster odd behaviour Electronics leroy 4 1974 16th March 2006 08:18 AM
98 Megane Speedomoter dropping to Zero Electronics chris m 2 1294 13th March 2006 10:52 AM
Rear Heated Screen problems on 98 Megane Electronics Uncle_Sam 5 2175 24th November 2005 12:03 PM
For the best viewing experience please update your browser to Google Chrome