Renault Forums :: Independent Renault forum - View Single Post - Renault Clio II - Electronics - TDC sensor

View Single Post
post #44 of (permalink) Old 20th February 2008
Join Date: Nov 2006
Posts: 41
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Question TDC sensor connector problems

I pass this on FWIW, but it makes sense to me:

I was told by a very experienced Renault mechanic that a lot of the problems with the TDC sensor are in fact with the connector. He said that in the dealers they routinely used to bend the connectors in the plug so that they have a tighter contact with the terminals in the sensor.

I had a problem with the TDC sensor on my Kangoo, removed it, cleaned the little metal tip, problem went away for a few weeks. Trouble was, the tip was hardly dirty and I couldn't see why 'cleaning' it made much difference. In the process, of course, I removed and reattached the plug, and it could well have been this that made the difference.

When it went wrong again I didn't bother removing the sensor but followed the mechanic's advice, along with some contact cleaner - I haven't had a problem for about 10 months now.

I know these TDC sensors are relatively cheap, but it would be nice to know how many are replaced completely unncecessarily, and whether what is actually fixing the problem is just unplugging and plugging the contacts!

The other thing that would be interesting - what exactly is the mode of failure of these units? Does the wiring for some reason break, does the tip become magnetized, or what?
Currently in Jlucy's garage:
Renault Kangoo and Clio
Jlucy is offline  
For the best viewing experience please update your browser to Google Chrome