Renault Forums :: Independent Renault forum - View Single Post - 2.0 RXE 'leccy fault dash etc...

View Single Post
post #3 of (permalink) Old 20th February 2008
Platinum member
Azurael's Avatar
Join Date: Feb 2008
Posts: 3,499
Nominated 0 Times in 2 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 7
Thanked 94 Times in 88 Posts
Send a message via MSN to Azurael
On my car, the temperature guage acts as an oil level indicator for a period of time after the ignition is switched on - it has a light to the side of it to indicate that this is happening.

I'm not sure if the Megane would have this, but I was under the impression this had been a feature of Renault cars for some time now. If the light indicating that the guage is reading oil level (red to orange running from bottom-to-top of the guage, with a little oil tank w/dipstick depicted next to it on mine - where the top of the guage is oil full, and the bottom low) goes off, as it should, that is the point that it would start indicating engine temperature.

If it reads 'low' when the light is on, and 'high' when the light is off, either your car's got low oil and is running hot (or is possibly suffering from faulty senders), or you're reading the guage back to front!
Currently in Azurael's garage:
TEB64 (Cosmic Grey) 2001 'Y' Laguna II 1.8 16v Privilege Tourer (KG0B F4P-770)/TED44 (Odyssey Blue) 2001 'Y' Laguna II 1.8 16v 'Expressionale' Hatch (BG0B F4P-770)

Last edited by Azurael; 20th February 2008 at 10:37 PM.
Azurael is offline  
For the best viewing experience please update your browser to Google Chrome