Renault Forums :: Independent Renault forum - View Single Post - Rear Nearside Light Cluster odd behaviour

View Single Post
post #1 of (permalink) Old 16th March 2006 Thread Starter
Junior Member
Join Date: Nov 2005
Posts: 11
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Rear Nearside Light Cluster odd behaviour


My 98 Megane has started to have some problems with the nearside rear light cluster. When indicating left, it's fine. If I brake aswell, the indicator continues to flash, but so does the brake light. If I turn on side lights aswell, the indicator flashing slows down, and the rear light and brake lights flash alternately.

I removed the old cluster, turned it over, and about half a pint of water came out. I replaced the cluster with a new one, but I'm getting similar problems (not exactly the same as before, this time the fog light also flashes!)

Front end is fine, offside rear is also fine.

Could this be a simple earthing problem, or a loose connection somewhere in the wiring? Any thoughts gratefully received!

Thanks, Steve
Currently in stevenh1978's garage:
'03 Ford Mondeo now, as his '98 Megane 1.9 Dti RXE was getting too expensive to fix!!
stevenh1978 is offline  
  5 Lastest Threads by stevenh1978
Thread Forum Last Poster Replies Views Last Post
1998 Megane erratic speedo Electronics swfcowl5 3 2066 4th November 2006 05:10 PM
Rear Nearside Light Cluster odd behaviour Electronics leroy 4 1971 16th March 2006 08:18 AM
98 Megane Speedomoter dropping to Zero Electronics chris m 2 1291 13th March 2006 10:52 AM
Rear Heated Screen problems on 98 Megane Electronics Uncle_Sam 5 2173 24th November 2005 12:03 PM
For the best viewing experience please update your browser to Google Chrome