Renault Forums :: Independent Renault forum - View Single Post - TDC Sensor Replacement (with pictures!)

View Single Post
post #109 of (permalink) Old 4th March 2008
Junior Member
AdrianJW's Avatar
Join Date: Jan 2008
Posts: 21
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 2 Posts
Yes it happened – Friday eve, about to come home and – car would turn over but not fire (and no petrol smell?)
Thought it was immobiliser but idiot lights all said it was okay!
Got spare key and tried – still no joy – Abandoned the car for the night!!

Next day ready to tow home and … the %&^$£”%^&* started first time!!

Went to Fish Brother, Reading and asked some questions – very helpful, they said a diagnostic check was £58 plus Vat, plus fix what’s wrong, but did say it may not find problem as its fixed itself – they thought it may be the TDC Sensor!

Okay rest of weekend until Monday morning and – same problem, I sprayed WD40m around the TDC Sensor and we-hey it started.

Read this excellent post (great pictures) then went home and had-a-go.

It took 30mins from off to on including cleaning – tools used = 10mm ‘long’ socket, long ext’n (threaded though pipes to rear bolt) short ext’n (under pipes to front bolt) and ratchet and a small piece of wetndry – must admit a lot of it is by feel not see!

Hopefully that’s fixed it

Currently in AdrianJW's garage:
2000 Scenic 2.0 Sport Alize
AdrianJW is offline  
For the best viewing experience please update your browser to Google Chrome