Renault Forums :: Independent Renault forum - View Single Post - help please, dash electrical problem!!

View Single Post
post #1 of (permalink) Old 9th March 2008 Thread Starter
Diamond member
jonny_g's Avatar
Join Date: Nov 2006
Posts: 324
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 12 Times in 3 Posts
Send a message via MSN to jonny_g
help please, dash electrical problem!!

hi all

within the last 2-3weeks of driving my clio, all the lights in the centre of the speedo cluster have lit for 1-2 seconds and then reset my milage trip and computer trip values. the overall mileage isnt affected. during this brief spell, there is no loss of power nor does the engine cut out.
any suggestions?

i would also add that this has only happened since i tried the diagnostic test thingy where you hold in the trip button and put on the ignition. coincidence?

suggestions much appreciated

Currently in jonny_g's garage:
Toyota corolla T3 2.0L D4D 116bhp
jonny_g is offline  
  5 Lastest Threads by jonny_g
Thread Forum Last Poster Replies Views Last Post
farewell to renault forums (sort of) General Chat jonny_g 6 4092 16th March 2010 01:18 PM
DCi losing power and glow plug light coming on Engines meganedti 17 15958 2nd August 2009 03:27 PM
Very good source for translating fault codes Electronics Ditchfield 8 137785 17th April 2009 11:51 AM
good renault mechanic in leicester/ east midlands... Cars & motoring narrowgauge 3 2971 5th February 2009 09:57 AM
For the best viewing experience please update your browser to Google Chrome