Laguna II - ABS not working but no warning lights ? - Page 11 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #51 of 82 (permalink) Old 12th December 2011
Member
 
dannyc's Avatar
 
Join Date: Dec 2011
Posts: 60
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 7
Thanked 11 Times in 8 Posts
Re: Laguna II - ABS not working but no warning lights ?

thanks for the reply

well all i can say is mission accomplished

i opted for just the ecu swap as a way forward to help all others WITHOUT REMOVING THE BUMPER, some may say im lazy some may say im a problem solver, i know what i am lol

removed the wheel any arch splash sheld i was gonna remove the bumper but 1 of the t25 screws on drivers side was spinning so thort f**k it and left the bumper on and just removed the one side *see pic* i know not the best way but meh
and to rub it in my bolts didnt snap on the inner arch where bumper is held up
i removed the 3 pump to braket mouting screws and the 2 braket to chassis bolts and bent the braket out the way (i know not the best) but i needed to, to remove the upper pump motor screw the lower one can be done through the hole at the bottom then its a case of bushing the radiator bottom hose out the way and spinning, twisting wiggling the ecu round and out to freedom i then set about fitting the new unit, which with out bending the 2 prongs which is really really hard, for your sake dont do this if you have the patience of a nat
anyway 2 screws back in nice and tight multi plug back on (very stiff) and a test run card in and all good so bend braket back and box back to gether when finished i went for a run, bit of speed on then gave it a stomp and felt the kick back through the pedal stright away all lights off job done

i must say that it sorted my problem it may sort many others but there may be some with sticky valves so dont moan at me if this dont fix yours and have to swap the block too
i really think the problen is the cheapness if the ecu if it would be better if they was soldered but thats my thort

time for some pluggin
whilst the wheel was off i noticed my tyre was ready for changing a local company did me a 225/45/17 z rated brand new sunny for 42 ok its not a michelin but a budget for 42 thats great so if your in hull
AJS Tyreman 07957206047
UNIT 2 180 ALBERT AVE, HULL, HU3 6QA



and finally a thanks to TTT there's loads of great info from you and i would of just swapped the full pump if not for reading all what you saidhave one on me, i might not of done it as any renault manual would but i did it my way
just got to do the engine running light now and rear axle bushes, i know which im doing first
Attached Thumbnails
Click image for larger version

Name:	P121211_13.020001.JPG
Views:	224
Size:	101.5 KB
ID:	14708   Click image for larger version

Name:	P121211_13.020002.JPG
Views:	221
Size:	100.3 KB
ID:	14709   Click image for larger version

Name:	P121211_14.080001.JPG
Views:	215
Size:	123.8 KB
ID:	14710   Click image for larger version

Name:	P121211_14.470001.JPG
Views:	199
Size:	117.4 KB
ID:	14711  
Currently in dannyc's garage:
2002 bmw 330 e46, 2012 ford transit connect

Last edited by Devils Laguna; 12th December 2011 at 11:46 PM.
dannyc is offline  
The Following User Says Thank You to dannyc For This Useful Post:
TTT (13th December 2011)
Sponsored Links
Advertisement
 
post #52 of 82 (permalink) Old 13th December 2011 Thread Starter
TTT
Platinum member
Technical Supremo
Threadstarter
 
TTT's Avatar
 
Join Date: Jun 2008
Posts: 1,985
Nominated 3 Times in 7 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 199
Thanked 399 Times in 348 Posts
Thumbs up Re: Laguna II - ABS not working but no warning lights ?

Excellent result, really glad you've sorted out your problem

I wasn't sure if there would be enough space to remove the ECU from the pump with it in situ, I didn't really look when I was changing my pump as I just changed the complete unit, but you have managed it so now we know it can be done.

You have also proved that the problem with your ABS was definitely the ECU.
As you mention this may not be the case every time as the valves in the valve block could be seized or something but I think in most cases it will be the ECU that causes the problem.

Although this thread is long and takes a bit of reading through I hope it helps others with their ABS problems.
Currently in TTT's garage:
2001 Renault Laguna II 1.9dCi Dynamique Sport Tourer
TTT is offline  
post #53 of 82 (permalink) Old 13th December 2011
Platinum member
 
Azurael's Avatar
 
Join Date: Feb 2008
Posts: 3,499
Nominated 0 Times in 2 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 7
Thanked 94 Times in 88 Posts
Send a message via MSN to Azurael
Re: Laguna II - ABS not working but no warning lights ?

So you mean every time I go fording with the N/S/F of my car, as frequently happens round here (B&NES not so great at clearing drains!), I'm soaking the ABS control unit? Great...

All murderers are punished unless they kill in large numbers and to the sound of trumpets. - Voltaire
Currently in Azurael's garage:
TEB64 (Cosmic Grey) 2001 'Y' Laguna II 1.8 16v Privilege Tourer (KG0B F4P-770)/TED44 (Odyssey Blue) 2001 'Y' Laguna II 1.8 16v 'Expressionale' Hatch (BG0B F4P-770)
Azurael is offline  
 
post #54 of 82 (permalink) Old 13th December 2011 Thread Starter
TTT
Platinum member
Technical Supremo
Threadstarter
 
TTT's Avatar
 
Join Date: Jun 2008
Posts: 1,985
Nominated 3 Times in 7 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 199
Thanked 399 Times in 348 Posts
Re: Laguna II - ABS not working but no warning lights ?

The multi plug connector seems very well sealed into the socket, not sure about fully submerging it tho.

You have to hand it to Renault tho, they really went for it and put the Glow plug relay down there also, it's bolted to the side of the bracket that holds the ABS pump


Cheers.
Currently in TTT's garage:
2001 Renault Laguna II 1.9dCi Dynamique Sport Tourer
TTT is offline  
post #55 of 82 (permalink) Old 13th December 2011
Platinum member
 
Azurael's Avatar
 
Join Date: Feb 2008
Posts: 3,499
Nominated 0 Times in 2 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 7
Thanked 94 Times in 88 Posts
Send a message via MSN to Azurael
Re: Laguna II - ABS not working but no warning lights ?

Quote:
Originally Posted by TTT View Post
You have to hand it to Renault tho, they really went for it and put the Glow plug relay down there also, it's bolted to the side of the bracket that holds the ABS pump
Well at least I don't have to worry about that one

All murderers are punished unless they kill in large numbers and to the sound of trumpets. - Voltaire
Currently in Azurael's garage:
TEB64 (Cosmic Grey) 2001 'Y' Laguna II 1.8 16v Privilege Tourer (KG0B F4P-770)/TED44 (Odyssey Blue) 2001 'Y' Laguna II 1.8 16v 'Expressionale' Hatch (BG0B F4P-770)
Azurael is offline  
Reply

Tags
abs , laguna , lights , warning , working

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome