Laguna II - ABS not working but no warning lights ? - Page 6 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #26 of 82 (permalink) Old 24th November 2011 Thread Starter
TTT
Platinum member
Technical Supremo
Threadstarter
 
TTT's Avatar
 
Join Date: Jun 2008
Posts: 1,985
Nominated 3 Times in 7 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 199
Thanked 399 Times in 348 Posts
Re: Laguna II - ABS not working but no warning lights ?

Have you tested to see if your ABS is actually working when the lights are out?

I think my problem may be either a wiring problem or the ABS ECU.


Cheers.
Currently in TTT's garage:
2001 Renault Laguna II 1.9dCi Dynamique Sport Tourer
TTT is offline  
Sponsored Links
Advertisement
 
post #27 of 82 (permalink) Old 24th November 2011
Member
 
trickyd400's Avatar
 
Join Date: Oct 2011
Posts: 48
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 4
Thanked 4 Times in 4 Posts
Re: Laguna II - ABS not working but no warning lights ?

No I haven't. Only been driving it gently due to clonking suspension! I shall try and seek out a chance to test it at the w/e hopefully.
Currently in trickyd400's garage:
2001 Renault Laguna II 1.9dCi Dynamique Estate, Ford Fiesta Mk6 1.25 Style, CBR400RR, Beta Zero Gara- now stolen!!! GRRRR!!
trickyd400 is offline  
post #28 of 82 (permalink) Old 27th November 2011 Thread Starter
TTT
Platinum member
Technical Supremo
Threadstarter
 
TTT's Avatar
 
Join Date: Jun 2008
Posts: 1,985
Nominated 3 Times in 7 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 199
Thanked 399 Times in 348 Posts
Thumbs up Re: Laguna II - ABS not working but no warning lights ?

I'm glad to report that I have fixed the problem by fitting a 2nd hand ABS pump


I got a 2nd hand pump from a local Renault breakers, the numbers on the 2nd hand pump matched the original pump except there was an "A" at the end of the first row, I guessed this was close enough so took a chance on it.

Numbers from new (2nd hand) pump:

8200 053 422 A
P5CT2AAY1
10 . 0206-0014 . 4




This is a picture of the OLD pump.





Apologies for not having photos of the job but our camera is packed away somewhere, I tried to take a few with the camera on my mobile phone but it had started to spit on with rain so it was quite dark and the pictures were no good.

Changing the pump.

Removed the front bumper, there's details on the forum of where the bolts are located, I had left some of the bolts out the last time I had the bumper off to check the ABS pump as I figured I may have to be back in at it, so it was just a few bolts to remove for me, not forgetting to disconnect the hose from the washer bottle to the headlight washers and the wires to the fog lights.

Before I disconnected any brake pipes from the old ABS pump I removed the multi plug and plugged in the new pump, there were no ABS warning lights on the dash with the new pump plugged in (they were on with the old pump plugged in) so I guessed the pump was ok, this inspired me to carry on in the rain and the winds...what I would give for a garage to work in

The ABS pump is housed inside a bracket, removing the bracket looked like a lot of work as some of the bolts holding the bracket require other items to be removed so I figured I could unbolt the pump from the bracket and by "Persuading" the brake pipes out of the way I could probably jiggle it out somehow....with a bit of jiggling and the odd pipe pushed here and there the pump came out.

I jiggled the new pump into position and connected up the brake pipes, it's a messy job as there is no real way to stop the fluid from dripping out of the disconnected pipes, I had placed a bucket under the pump and this was catching the brake fluid that was coming from the disconnected pipes, none the less brake fluid is horrible, it makes your hands "Squeaky" and you can't grip anything.

I took my time in connecting the brake pipe unions to the new pump, its very easy to cross thread them so I made sure I got them all started nice and square, you can feel if they are going in correctly, so best to do them up with your fingers, giving the pump the odd shake as you go to release the tension on the unions helps . Once the unions were finger tight it was just a couple of nips on each with the 11mm spanner.

With all of the pipes connected I cleaned down the pump to get rid of the brake fluid that leaked onto it during the fitting. I then connected the multi plug and turned on the ignition, as before the ABS warning lights were out....looking good.

I started the car and the "STOP" & the ((o)) (handbrake warning light) were on, this was just down to the brake fluid level dropping, I topped up the brake fluid and the warning lights went out.
With the engine running I got the other half to press the brake peddle while I looked for leaks from the pipes, no leaks so all was well.

I refitted the bumper, I'll get round to fitting all of the bolts in the summer .

Next bleeding the brakes, I have a pressure bleeder, the type that works from the pressure of the air in the spare wheel, so I hooked that up and went round each wheel caliper, I got a couple of small air bubbles through at each but not masses of them, I wasn't expecting too as the pump was full of fluid so any air in the system would have only been from the fitting of the pipes to the pump.
After bleeding the system the peddle felt just the same as it did before I started.

All done, I took the car out to test the ABS with the "Gravel test"....result....the ABS kicked in when I stood on the brakes, I gave it a few goes and the ABS system is now working as it should.

I'm happy to finally find the cause of my intermittent ABS warning lights. There were days when the warning light would come on, then there were days when it was off, this made diagnosing the problem harder, but I got there in the end.

Thanks to everyone who contributed along the way I hope this thread helps someone else sort out their ABS problem.


Cheers.


@trickyd400,

The problems you are suffering sound very similar to mine, I wonder if your pump is playing up!
Currently in TTT's garage:
2001 Renault Laguna II 1.9dCi Dynamique Sport Tourer
TTT is offline  
The Following 4 Users Say Thank You to TTT For This Useful Post:
bobbydog (27th November 2011), dannyc (11th December 2011), PheoBlue (21st December 2011), tolsen (27th November 2011)
 
post #29 of 82 (permalink) Old 27th November 2011
Member
 
trickyd400's Avatar
 
Join Date: Oct 2011
Posts: 48
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 4
Thanked 4 Times in 4 Posts
Re: Laguna II - ABS not working but no warning lights ?

Good job TTT. Thanks for the details, gives me the confidence to do the same. I'll be trying to get a second hand ABS pump now and have a go before the winter sets in....
Currently in trickyd400's garage:
2001 Renault Laguna II 1.9dCi Dynamique Estate, Ford Fiesta Mk6 1.25 Style, CBR400RR, Beta Zero Gara- now stolen!!! GRRRR!!
trickyd400 is offline  
post #30 of 82 (permalink) Old 27th November 2011 Thread Starter
TTT
Platinum member
Technical Supremo
Threadstarter
 
TTT's Avatar
 
Join Date: Jun 2008
Posts: 1,985
Nominated 3 Times in 7 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 199
Thanked 399 Times in 348 Posts
Re: Laguna II - ABS not working but no warning lights ?

Hi,
I'm not sure but maybe a pump with different numbers would have worked but if you can it's probably worth trying to get one that matches the original just in case.

Shop round for a pump as one of the breakers I rang wanted 80, the Renault breakers charged me 30.
There's a lot of pumps on ebay so you won't be stuck finding one.

Let us know how you come on as the more info we can post up the better, it will help others if they have the problem.

Cheers.
Currently in TTT's garage:
2001 Renault Laguna II 1.9dCi Dynamique Sport Tourer
TTT is offline  
Reply

Tags
abs , laguna , lights , warning , working

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome