Clio II ABS / Speedo Problems - Page 3 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 17th February 2012
Junior Member
diamond69's Avatar
Join Date: Jul 2011
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Re: Clio II ABS / Speedo Problems


i have a clio 2.2 1.4l 16V privilege 2002.
i have a similar probs
prob 1:. when wiper on intermittent, sometimes in goes in continuous until i press the brake pedal then it stops,as soon as i release pedal, it goes into continuous mode again
prob2: i can hear a relay clicking under the dash (i think) when i accelerate then clicks again when i apply brakes.

your comments will be much appreciated
Currently in diamond69's garage:
2002 renault clio II phase II 1.4 16V
diamond69 is offline  
Sponsored Links

abs , clio , problems , speedo

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome