Wierd noise from the Brake Servo Megane mk2 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 4th December 2011 Thread Starter
Junior Member
Join Date: Dec 2011
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Wierd noise from the Brake Servo Megane mk2

Hi all. i've got a RENAULT MEGANE II 2006 2.0 dci hatch running on 47,000 miles, and have recently been experiencing a funny noise coming from the front passenger side of the car, possibly from the break servo. when the engine starts, so does the noise. when you press the breaks the noise stops but when you release the breaks the noise starts again. i also noticed that when i start the car in the morning, the break pedal is very hard, and when the engine starts it softens. this hadnt happen before. if there is anyone who has experienced such an issue or knows anything about it, please let me know as to what i should do, and if it's serious or i can continue driving normaly?

many thanks
Currently in chochkov's garage:
2006 Renault Megane II 2.0dCi
chochkov is offline  
  5 Lastest Threads by chochkov
Thread Forum Last Poster Replies Views Last Post
Wierd noise from the Brake Servo Megane mk2 Brakes/Hubs mord 1 1598 4th December 2011 09:43 PM
Sponsored Links
post #2 of 2 (permalink) Old 5th December 2011
Platinum member
mord's Avatar
Join Date: Jun 2009
Posts: 5,250
Nominated 3 Times in 11 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 47
Thanked 514 Times in 490 Posts
Re: Wierd noise from the Brake Servo Megane mk2

hi and welcome to the forums

what does the sound sound like?

the brakes will be very hard whilst the engine isnt running(as on any car!) as you have no vacumn servo assistance from the brakes which relies on the engines inlet manifold for the vacumn.
Currently in mord's garage:
The CreditCard Holes sooo DEEEEP NASA have put up warning signs about a black hole on the Driveway: update, the driveway and home have fallen in...
mord is offline  

brake , megane , mk2 , noise , servo , wierd

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome