Clio Brakes ?????? - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 20th December 2011 Thread Starter
Junior Member
Join Date: Aug 2011
Posts: 17
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 1 Time in 1 Post
Clio Brakes ??????

Hi Everyone, I have searched and cant seem to find an answer so hope that someone on here can please help me out,

I have a Clio 2005 and have recently had a lot of work done it, to be honest the work did not really need to be done but I have never really spent much money on the car so thought that I would get most things done.

Basically the work that was done was track rods, ball joints and brakes but I now have an issue and the garage who done the work can not get to the bottom of the issue ???? The issue being that when I brake when say at 40 mph I get a pulsing on the foot brake and the car pulls to the right?? I have the front pads, discs and also the rear shoes were replaced. but since I have had the issue they have tried everything,
I took the car for an mot today and it passed ????? no advisories and also it was a different garage from the one that did the work before, So I asked them to check the car out and they have said that they can feel the pulsing and pulling on the car so they had everything checked out but to no avail, they have said they they can change the brake lines but I really dont know what to do as I have now spent way more than I wanted but have to get this sorted as had to hire a car until its fixed or am going to have to buy a new car which I dont really want to do either.

Has anyone ever expierenced this or could anyone give me a clue to what maybe going on

any help would be greatly appreciated
Currently in cglasgow82's garage:
Megane 2005 1.6 16v
cglasgow82 is offline  
  5 Lastest Threads by cglasgow82
Thread Forum Last Poster Replies Views Last Post
Upgrading brakes Brakes/Hubs cglasgow82 2 596 28th March 2014 10:51 PM
Permiwrap Bodywork cglasgow82 0 809 26th March 2014 01:28 AM
Bolt destroyed :( :( Help Please Wheels & tyres mickeybo 4 1025 22nd July 2013 07:15 PM
Megane Fuel Pump Engines whizzy41 1 867 25th March 2013 11:39 PM
Sponsored Links
post #2 of 3 (permalink) Old 21st December 2011
Technical Supremo

Join Date: Feb 2007
Posts: 42,940
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,200 Times in 4,712 Posts
Re: Clio Brakes ??????

Faulty ABS sensors or reluctor rings or possibly a duff ABS control unit.
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
post #3 of 3 (permalink) Old 21st December 2011
Junior Member
Join Date: Dec 2011
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Clio Brakes ??????

The first question is what was done to the brakes? Can you feel judder in your steering when you brake? Have the front brake discs been replaced?

If so it could be that they are not seated correctly and when you are braking you are getting a 'wobbly record' effect. This can be due to the flange not being cleaned up well enough before fitting the new discs.
Get the garage that fitted the discs to put a 'dti' gauge on the discs and check them for 'run out'.
Max run out should only 10 thousandths of an inch.

Brake hoses will not cause this problem.

Best of luck and let us know how you get on.

Currently in favnick's garage:
2001 laguna 1.8
favnick is offline  

brakes , clio , pedal , pulling , pulses

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome