Reset electronic handbrake,LOOK HERE - Page 29 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #141 of 141 (permalink) Old 21st June 2016
Junior Member
Steven McKenna's Avatar
Join Date: Jun 2016
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to Steven McKenna
Re: Reset electronic handbrake,LOOK HERE

Hi guys, I just joined, have to say I ve found the information on here invaluable... really helped me a lot!

I had a problem with EPB and took it off, I disassembled the motor here is a link to my video
Disassembling Renault Scenic Motor

I will do a follow up video when I source a motor (the Johnson motor or equivilent)

If anybody here could suggest a place to purchase one in Ireland or the UK that would really help me out.

thanks again for all the great help.

Steven McKenna is offline  
Sponsored Links

electronic , handbrake , hear , reset

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome