clio 03 1.5 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 24th July 2012 Thread Starter
mick65's Avatar
Join Date: Jun 2010
Posts: 33
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 4
Thanked 2 Times in 2 Posts
clio 03 1.5

hi ive developed a vibration on the front end when i break a little bit harder than normal upto now iv changed discs/pads new coil springs and the small link arms and still have the vibration.checked breaks on rollers no binding please any advive ,the wishbone bushers look like they will need coing for next mot the only thing iv not changed
Currently in mick65's garage:
vauxhall astra/ford focus/clio dci
mick65 is offline  
  5 Lastest Threads by mick65
Thread Forum Last Poster Replies Views Last Post
immobilizer Electronics Ralph 2 734 25th January 2013 05:57 PM
clio 03 1.5dci Engines mick65 0 661 12th January 2013 04:04 PM
clio 03 1.5dci Electronics mick65 2 655 14th December 2012 01:23 PM
serv/airbag Electronics lancs dave 3 2075 27th November 2012 09:05 AM
serv/airbag Electronics mick65 0 413 26th November 2012 05:13 PM


Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome