Scenic - Failure to release parking brake following rear pads replacement - Page 4 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #16 of 16 (permalink) Old 25th October 2014
Join Date: Oct 2014
Posts: 43
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 5
Thanked 0 Times in 0 Posts
Re: Scenic - Failure to release parking brake following rear pads replacement

Originally Posted by Nottnoc View Post
Seems like the EPB box is jammed.
or the cables are seized.
Have you ever pulled the emergency release?
Perhaps you may have to, Then read this thread
Last ditch is to open the EPB box & wind it manually.
This thread has pictures
Hope this Helps
The cables look to be in good condition and seem to move. The handbrake was also working perfectly before I fitted new rear pads. I have tried to pull the emergency brake as part of the re-set procedure but I do not feel anything releasing when I pull it - perhaps I need to pull it harder?
Currently in grandscenic12's garage:
Renault Grand Scenic
grandscenic12 is offline  
Sponsored Links

brake , failure , fitting , pads , parking , rear , release , replacement , scenic

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome