2003 Laguna ABS problem - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 29th August 2013 Thread Starter
Junior Member
Join Date: Aug 2013
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
2003 Laguna ABS problem

Hi all,

I have 'SERV' and ABS lights displayed on my dash. The back bearings / rings were recently replaced and everything was working fine until recently when the above lights came on, I got a local garage to scan for fault codes and it was displayed front N/S sensor failed. So I have now replaced this but the metal ring that supports the sensor is goosed! Upon struggling to get the hub free, I'm now thinking is the whole bearing to be changed out now for a new holding ring? How exactly does this system work with no toothed ring? And also upon getting everything back in good shape will the fault code reset automatically?

Hope this makes sense to someone, and look forward to your replies....

Currently in aj85's garage:
Laguna 2.0 16v Mk2
aj85 is offline  
  5 Lastest Threads by aj85
Thread Forum Last Poster Replies Views Last Post
2003 Laguna ABS problem Brakes/Hubs aj85 0 760 29th August 2013 09:27 PM

abs , laguna , problem

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome