Newbie needs help.... - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 2nd September 2013 Thread Starter
Junior Member
Join Date: Apr 2013
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Newbie needs help....

Hi, I have a Megane trophy 225, had to slam the brakes on about 5 weeks ago and since then I've had the ABS fault light come on randomly. The last 2 weeks I've also noticed a slight grabbing/grinding when applying the brakes, only when I touch it lightly tho. Had the pads and discs checked and its all fine, garage told me it was a snapped 'boot clip' (not sure what that is) it was replaced, however still not rectified and ABS fault light is almost constantly on. Any ideas as to what this could be?

Thanks for any advice
Currently in ashton1's garage:
Megane Trophy
ashton1 is offline  
  5 Lastest Threads by ashton1
Thread Forum Last Poster Replies Views Last Post
Newbie needs help.... Brakes/Hubs TazzyK 1 506 2nd September 2013 09:37 PM
New user Welcome to RenaultForums IT66 3 607 5th April 2013 10:07 AM
Sponsored Links
post #2 of 2 (permalink) Old 3rd September 2013
Platinum member
TazzyK's Avatar
Join Date: Mar 2006
Posts: 1,076
Nominated 0 Times in 4 Posts
Nominated TOTW/F/M Award(s): 2
Thanks: 30
Thanked 73 Times in 63 Posts
Re: Newbie needs help....

Not sure what the boot clip is, but I would check the plug to the abs sensor at the front of the car (both sides). Unplug, clean, and plug back in securely.

Mine had somehow disconnected completely (a week or so after a clutch change), so the garage just applied some grease and fitted it back on. Engine on, turn the whell by hand, and the light went off.

Might be worth a check.....
Currently in TazzyK's garage:
Renault Clio 1.4 16v Privilege (2004), Renault Megane 1.5 dCi 106 Expression (2005), Volkswagon Passat 2.0 TDi S (2006), Alfa Romeo 159 2.4 JTDm QTronic Lusso (2008)
TazzyK is offline  


Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome