laguna owner looking for advice on a brake issue - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 26th September 2013 Thread Starter
Junior Member
Join Date: Sep 2013
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Red face laguna owner looking for advice on a brake issue

hi, new member here. after a few days getting no results from friends looking at my car i decided to come on here and ask you guys.

2003 laguna 1.8

symptoms - brakes juddering especially at low speed (abs activating)

no ABS light on dash

removed the ABS fuse and juddering went away so discs, calipers, pads ok

now it looks to be possibly a bad ABS ring but if you guys with more experience could shed some light on a possible solution that would be much appreciated.


just realized i could have done a search before asking but ive typed it now so....
Currently in laguna1981's garage:
2003 laguna 1.8
laguna1981 is offline  
  5 Lastest Threads by laguna1981
Thread Forum Last Poster Replies Views Last Post
laguna owner looking for advice on a brake issue Brakes/Hubs daveyboy58 1 761 26th September 2013 08:40 PM
Sponsored Links
post #2 of 2 (permalink) Old 27th September 2013
Join Date: Oct 2008
Posts: 99
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 42
Thanked 30 Times in 22 Posts
Re: laguna owner looking for advice on a brake issue

Welcome to the forum!
I had exactly the same symptoms as yourself on my clio.I did exactly the same as you regarding the fuse etc.Close look at the reluctor rings and discovered two hairline cracks in drivers side front driveshaft.The ring was quite corroded as well.I got a new one off the auction site for 6,and fitted it myself after removing the shaft.Problem solved.I must admit,at first i thought it was the pads worn down to the metal backing,it was a very strange grinding,nearly got the better of me actually!
Currently in daveyboy58's garage:
2011 laguna 2.o dci 175hp and a 2003 12 16v clio
daveyboy58 is offline  

advice , brake , issue , laguna , owner

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome