2002 Clio 1.2 16v - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 19th February 2014 Thread Starter
Junior Member
Join Date: Jan 2014
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
2002 Clio 1.2 16v

I hit a stone a month ago at about 65mph, and smashed the alloy and gouged the tyre. The car at the time was at about 98950 miles and i replaced the rear wheel bearings at about 98500 and basically when i smashed the alloy there is a whump sound from the rear again (i think) and is there a possibility the bearing could be gone again? Thanks in advance
Currently in Kirkyyb447's garage:
Renault Clio 1.2 Dynamique 16V
Kirkyyb447 is offline  
  5 Lastest Threads by Kirkyyb447
Thread Forum Last Poster Replies Views Last Post
2002 Clio 1.2 16v Brakes/Hubs Kirkyyb447 0 357 19th February 2014 12:49 AM

16v , clio

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome