55 Megane 2.0 Petrol (Brake Issue) - Page 2 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #6 of 6 (permalink) Old 26th April 2014
Honorary Yorkshireman just in Derbyshire
Nottnoc's Avatar
Join Date: Dec 2008
Posts: 6,531
Nominated 19 Times in 15 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 1,572
Thanked 1,689 Times in 1,292 Posts
Re: 55 Megane 2.0 Petrol (Brake Issue)

Just done a Scenic TRW rear pad change, brought on by seeing the state of them, whilst having an unexpected tyre replacement.
Remembering this thread, I too, found the pedal spongy afterwards. Not even going to consider a fluid change until June, when hopefully, the pads will have settled down. Took some piccy's, may help someone, especially the use of a Hub puller & some footprint grips (not shown) to rewind the pistons, Apply pressure, turn clockwise, repeat until bellows are fully compressed & Caliper will slide easily over the new pads.
WARNING, If you have an Electronic handbrake:-
Chock the wheels, Put in gear, Loosen wheel nuts, Apply footbrake (not the Clutch), Press start (Dash will nag to put in Neutral, IGNORE). Steering lock will come off, but engine will not start. Release handrake (will beep like crazy, IGNORE), get out, shut door.
As long as the car knows the handbrake is off, the auto handbrake will not try to apply the brakes harder, should any disks be moved whilst working. DO NOT FORGET to refit the handbrake cables before testing. Otherwise a manual release, reset, & possibly a diagnostic reset will be necessary. Good luck.

Regards Tim,
You are only young once, but you can be immature forever
Give a n00b the answer he will be learn for a day; show him the search button, he will learn for life.
Currently in Nottnoc's garage:
2008 Scenic Mk2 Dynamique 1.6 K4M 782. 1998 BMW K1100LTSE, 1994 MotoGuzzi Caifornia 3 LAPD, 1972 Norton Commando, 2010 Trafic SL29 M9R782 115, Lots of tools, Camping Gear & Booze

Last edited by Nottnoc; 15th August 2016 at 03:31 PM.
Nottnoc is offline  
Sponsored Links

brake , issue , megane , petrol

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome