New electronic handbrake still not working properly help - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 27th May 2015 Thread Starter
Junior Member
Join Date: May 2015
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy New electronic handbrake still not working properly help

hi all
I am new here to posting although. Look for all up all my car problems on this forum. Whilst driving back from Cambridge had a beep and warning light handbrake fault. Handbrake not working apt all. Abandoned the trip and drove back to Leicester. I had, had my car for mot and garage said handbrake cable corroded. Anyway decided based on corrosion and fault to get new one fitted. Found Renault specialist in Leicester. Booked it in. Had new pads and new electronic handbrake that was 6 weeks ago. Collected the car and radio not coming on...hmm strange , radio burst into life later same day...just came on! car drove fine for 3 days then same beep warning parking brake fault. Handbrake not working. Back to garage who basically reset it. Sometimes it will just reset itself and all work fine. Then it will go again.Fine for 2 days then same problem. He has had it on and off hills trying to configure it? But every week same problem I've been raking it in for 6 weeks now. When I collect it's fine then within 2/3 days it all starts again. This week I feel in actually in tune with the bloody car. If the beep and the parking brake fault cones on. I've switched the engine if waited 2 mins stared the car and hey presto it all works...for 2 days then it all happens again. Can anyone point me in a direction of a possible solution the garage says keep bringing it back to home, but for 6 weeks half the week I have no car as its in said garage any advice much appreciated.
Currently in Carolann's garage:
Renault grande scenic
Carolann is offline  
  5 Lastest Threads by Carolann
Thread Forum Last Poster Replies Views Last Post
New electronic handbrake still not working... Brakes/Hubs Carolann 0 315 27th May 2015 08:39 AM

electronic , handbrake , properly , working

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome