Electronic handbrake on - motor still works - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 9th June 2016 Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Electronic handbrake on - motor still works

I bought a 2007 grand scenic a few weeks ago. The electronic handbrake was stuck on and car wouldn't move, but I found the manual release under the boot and got it home.

Planning on having a look at the car over the summer holidays while the kids are off school. I've read several posts about the electronic handbrakes, from trying the reset to removing the unit under the car and trying to repair or replace it. Probably missed a few threads too.

I can hear the motor running inside the electronic handbrake unit when I do the reset, but it fails to put the handbrake on and shows a parking brake fault on the dash.

I've still to check under the passenger seat for corrosion.

The back discs are badly worn, could this cause the electronic handbrake to stay on? Could a faulty caliper cause the electronic handbrake to stay on?

Was just wondering if there is anywhere else I could check? Don't think the cables are snapped because the back brakes both released as soon as I pulled the manual override.

The brake pedal is spongy as well, and clutch biting point very high. Probably not related to handbrake issue but thought I would mention it.

Thanks

Last edited by sl75; 9th June 2016 at 03:34 PM.
sl75 is offline  
  5 Lastest Threads by sl75
Thread Forum Last Poster Replies Views Last Post
Electronic handbrake on - motor still works Brakes/Hubs sl75 3 285 9th June 2016 03:14 PM
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 27th July 2016
Junior Member
 
Join Date: Jul 2016
Posts: 23
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 2 Posts
Re: Electronic handbrake on - motor still works

If the handbrake was holding which it sounds like it was first thing to probably check is the handbrake switch to make sure it's working as it fails commonly.
Shoaib123 is offline  
The Following User Says Thank You to Shoaib123 For This Useful Post:
sl75 (1st August 2016)
post #3 of 4 (permalink) Old 28th July 2016
Veteran Member
Technical Supremo
 
Dancingdad's Avatar
 
Join Date: Dec 2013
Posts: 10,694
Nominated 40 Times in 35 Posts
Nominated TOTW/F/M Award(s): 13
Thanks: 992
Thanked 2,025 Times in 1,586 Posts
Re: Electronic handbrake on - motor still works

Just checking that you've reset properly?

The manual over-ride in the boot disconnects a link inside the EPB module.
The reset should manually (from dashboard) drive the unit as far as it can to release the brakes and re-latch the link.
So it must be push the release button and pull the handle and hold to give the EPB chance to relatch.
Currently in Dancingdad's garage:
Qashqai 1.6 spark driven, Kia Sedona 2.9 TDI, Scenic II 15DCi 2004 (SORN) not quite RIP.
Dancingdad is offline  
 
post #4 of 4 (permalink) Old 1st August 2016 Thread Starter
Junior Member
Threadstarter
 
Join Date: Jun 2016
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Electronic handbrake on - motor still works

Quote:
Originally Posted by Dancingdad View Post
Just checking that you've reset properly?

The manual over-ride in the boot disconnects a link inside the EPB module.
The reset should manually (from dashboard) drive the unit as far as it can to release the brakes and re-latch the link.
So it must be push the release button and pull the handle and hold to give the EPB chance to relatch.
I tried the manual reset (using a guide I found on here) and could hear the EPB motor working but the cables would not relatch.

I ended up taking the EPB motor off, it was screwed right up and I noticed a small bubble on the g8nd2 relay on the PCB (indicating overheating). Have ordered a new relay and rear discs and pads. Hoping to have all the parts here by this weekend.
sl75 is offline  
Reply

Tags
electronic , handbrake , motor , works

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome