ABS Pump - Laguna - Page 2 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #6 of 8 (permalink) Old 19th August 2016
Platinum member
Technical Supremo
TTT's Avatar
Join Date: Jun 2008
Posts: 1,949
Nominated 3 Times in 7 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 197
Thanked 397 Times in 346 Posts
Re: ABS Pump - Laguna

You may find this thread helpful ......

Laguna II - ABS not working but no warning lights ?

Read from post # 24

ours2012 likes this.

Please take the time to enter your vehicle details in the "What's current in your garage?" box.

To do this:
Hover over the "TOOLS" tab at the top of the page
> then in the dropdown click on "User Dashboard"
> click on "Edit Your Details" at the top Left hand side.
> scroll down to the "What's current in your garage?" box and enter your vehicle details.
> Once the details are entered scroll down to the bottom of the page and click "Save Changes"

> Done.
Currently in TTT's garage:
2001 Renault Laguna II 1.9dCi Dynamique Sport Tourer
TTT is offline  
Sponsored Links
post #7 of 8 (permalink) Old 29th August 2016 Thread Starter
Junior Member
Join Date: Aug 2016
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Re: ABS Pump - Laguna

Thanks for your help guys, unfortunately this has me tied in knots. I think I might be able to get a part after all, but I have been told that you can't put second hand ABS pumps on the car as they have to be programmed.

Around three weeks ago I asked the garage to tow the car back to my home and I was going to put it off the road for a while. The garage (where my car has been sitting for six weeks) told me that I had no brakes and therefore couldn't drive the car.

Between the warning light coming on and the garage taking the car, I was driving around normally for about a week. (Initially it was thought that it could be the sensors that are the problem, not the pump itself). When they decided that the pump was faulty, the car was off the road. That was about six weeks ago.

Today I received notification from another garage that I could drive the car - the only problem was, the ABS wouldn't work but the brakes would still work and the car was still safe.

My question is - is it safe to drive this car with a faulty ABS pump, short term and long term and will this pass an MOT?

P3ter is offline  
post #8 of 8 (permalink) Old 29th August 2016
Official tight fisted Jock
batfink5's Avatar
Join Date: Apr 2015
Posts: 11,375
Nominated 7 Times in 7 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 1,530
Thanked 1,387 Times in 1,128 Posts
Re: ABS Pump - Laguna

Instant MoT failure and I wouldnt drive it about going by your description of the fault

My super sonic sonar radar will help me!
Currently in batfink5's garage:
Laguna MKIII 2.0dci dynamique, Clio dynamique tom tom, Vauxhall zafira
batfink5 is offline  
The Following User Says Thank You to batfink5 For This Useful Post:
P3ter (29th August 2016)

abs , laguna , pump

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome