scenic 1 brakes. - Page 4 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #16 of 17 (permalink) Old 4th November 2008 Thread Starter
Diamond member
glenlesjd's Avatar
Join Date: Dec 2007
Posts: 407
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
yep. will now be going to our renault friend who has his own garage.
Currently in glenlesjd's garage:
Laguna 1, Scenic 1, Fiesta ASBO
glenlesjd is offline  
Sponsored Links
post #17 of 17 (permalink) Old 5th November 2008
Diamond member
Join Date: Jul 2008
Posts: 481
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 4 Times in 4 Posts
no brakes

certainly sounds like front discs warn, to be that bad, its a wonder a warning wasnt issued on last MOT check. normally if that bad, the disc is probably going to need machining or replaced.
Currently in petercee's garage:
1998 scenic rxe
petercee is offline  

brakes , scenic

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome