Renault Laguna 1 - No Brakes! - Page 2 - Renault Forums :: Independent Renault forum

Brakes/Hubs Brakes, Hubs, and etc

LinkBack Thread Tools Display Modes
post #6 of 7 (permalink) Old 24th November 2008
Platinum member
Join Date: Jan 2006
Posts: 2,637
Nominated 0 Times in 4 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 48
Thanked 372 Times in 284 Posts
A very lucky escape by the sound of it Thankfully it's something I've never suffered ......... although brake fade has been experienced and it too can be quite an eye opener


I think I have CDO. It's like OCD, but with ALL THE LETTERS IN THE RIGHT ORDER
Currently in Gonescenile's garage:
A wee French toy & a 2010 Honda VFR 800
Gonescenile is offline  
Sponsored Links
post #7 of 7 (permalink) Old 24th November 2008
Posts: n/a
I guess if it can happen to you, it can happen to any of us

I've had similar experiences to you GS, but never a complete failure

brakes , laguna , renault

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome