Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II 1.9Dci - Engines - Hesitation Cured after EGR cleaned

View Single Post
post #73 of (permalink) Old 24th March 2008
nev.mason's Avatar
Join Date: Mar 2006
Posts: 42
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hello all,

I've noticed lots of info on this topic about being careful when extracting the EGR as it may snap off leaving one half inside the manifold. Well err, I was very careful and used lots of penetrating oil and left it for a good hour to soak in.

It came off in in two parts! when I examined the solenoid part of the valve the shaft look as if it was engineered in two parts or it was a clean break. I attempted to test the solenoid but it wouldn't operate at first then burst into life. Gave it a good clean and then removed the rest of the valve. It was well tarnished but free of deposits and oil . The manifold was another story. Chocked full of thick oily deposits. I've cleaned it best I can without removing the manifold finished cleaning the two half's of the valve and then put it all back together.

No difference at all! I'm wondering if the valve is totally knackered or its a problem with the Turbo . There is so much oil in the feed pipe to the inlet and when I ran the engine without the pipe connected to the manifold there was no clear sound of Turbo whistle or the associated whoosh with positive boost. Performance can be said as below average and lumpy between 2 and 3k on the tacho on boost and then runs out of steam at 3.5k.

All the sensors have been tested and are working and the glow plugs are good. Anyone shed some light on this for me?

Currently in nev.mason's garage:
2003 Laguna 1.9 DCI Initiale Sport Tourer
nev.mason is offline  
For the best viewing experience please update your browser to Google Chrome