Renault Forums :: Independent Renault forum - View Single Post - Laguna SERV Light

View Single Post
post #1 of (permalink) Old 26th March 2008 Thread Starter
Junior Member
Join Date: Jul 2007
Posts: 26
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Laguna SERV Light

I own a 98 Laguna 1.9 Dti. For about a week the SERV light has been coming on when I'm driving. It only comes on at low speed/revs and has been coming on more frequently as the week's progressed. It was suggested that the brake fluid might be low and causing the light to come on.
Brake fluid level ok, so it's not that, a diagnostic check revealed a faulty IAT sensor, I replaced it and the light still comes on. I was advised (maybe wrongly) that there was a second IAT senser built into the MAF sensor so I replaced that as well, the light still comes on. I have checked all of the wiring to the associated parts and all seems fine. I'm hoping to get it back onto the diagnostics machine soon but am trying to fix it in the mean-time.
It seems that as time goes on the light comes on more frequently, sometimes on for only a couple of seconds but it has stayed on for 2 minutes or so.
Only the SERV light comes on, no others with it. I also think the car feels slightly underpowered

Any advice would be greatly appreciated.
Currently in gusnjus's garage:
A Scenic 1.9 Dti RXE Monaco, A Laguna 1.9 Dti RXE Estate, A Laguna 1.9 Dti RT and a Skoda Octavia 1.9 GLX

Last edited by gusnjus; 10th April 2008 at 03:28 AM. Reason: Added more info
gusnjus is offline  
  5 Lastest Threads by gusnjus
Thread Forum Last Poster Replies Views Last Post
Renault Scenic Gearbox Problem Transmissions pragmatix 2 3748 24th January 2010 10:01 PM
Laguna dti lectrical problems Electronics gusnjus 1 1069 9th March 2009 09:04 PM
1998 laguna dti not starting Engines gusnjus 4 1072 28th February 2009 08:58 PM
Laguna SERV Light Electronics gusnjus 3 1467 26th March 2008 05:33 PM
For the best viewing experience please update your browser to Google Chrome