Renault Forums :: Independent Renault forum - View Single Post - Scenic I: mid-HG replacement photos

View Single Post
post #34 of (permalink) Old 13th April 2008 Thread Starter
Diamond member
mojolicious's Avatar
Join Date: Apr 2007
Posts: 658
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Cat got yer tongue, Noel?

RadFlushed. What a pain in the that is. Can't remember quite how many times I had to remove the air filter housing and the bottom hose. And the top hose. And all that fast idling for 20 or 30 minutes. Disappointed by the (visible) results.

My hot air's still cold when stationary, and I could only get 4.5l of coolant in there (should be 6l, although there's presumably a fair bit of old stuff left in the bottom of the radiator. It's the highest bottom hose I've ever encountered

The two heater matrix pipes are both pretty hot and solid (the lower one, which has the bleed valve attached, less so). Hopefully it will shift itself, or something.

Changed oil and filter. The 'old' oil was discoloured but not too badly. There was no sign of mayo in the filler cap, so that's one success story.

Universal Blued the throttle housing/manifold join. Idle came up to a beautiful 850ish, but have subsequently dropped back to 750-800rpm. Guess I'll have to get the paper gasket.

Bloody alternator belt is too bloody loose and I couldn't bloody move it... had free movement to slacken, but for some reason it just wouldn't slide beyond a certain point on the slidey bracket thing. Think it's slightly improved - the start-up squeal is briefer than before, and disappears altogether after a few minutes driving - but I need an extra hand to try and address it properly.

Total man-hours to date: I don't want to think about it.
Currently in mojolicious's garage:
2001 Ford Focus 1.9TD(d)i Estate in the incredibly luxurious 'LX' trim :)
mojolicious is offline  
For the best viewing experience please update your browser to Google Chrome