Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 2 - New Turbo,No Boost*FIXED*

View Single Post
post #7 of (permalink) Old 27th April 2008 Thread Starter
Junior Member
Join Date: Feb 2007
Posts: 22
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by lagdti View Post
IC is more commonly known as the Intercooler.It's possible that it's either full of oil or split.

The EGR valve is also a very common problem as said before.

I'd also check the boost side hoses for splits,check the airflow meter/air filter,and also all the vaccuum hoses and boost control solenoid connections and boost pressure sensor connections.

The Inter cooler is fine. It had a cup full of oil in there so I flushed it out with Petrol which would have found a split if there was one. If anyone does flush the Inter cooler out with fuel. Please remember to allow the fuel to evaporate off or blow it through to get all the fuel out.

The EGR valve is OK as well luckily. I went to clean it this morning and found the small vaccum pipe from the solenoid behind the intake pipe had been pulled off when they attached the other end to the turbo !

All is well with the world now! The power is well up from the previous turbo which must have been faulty when it was fitted. Not sure what the Power is up to now but it feels a good 10-15 BHP up!
Currently in morepower's garage:
2000 Scenic RX4
morepower is offline  
For the best viewing experience please update your browser to Google Chrome