Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 1 - No Brakes!*FIXED*

View Single Post
post #1 of (permalink) Old 3rd May 2008 Thread Starter
Junior Member
Join Date: Jul 2007
Posts: 27
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Renault Clio 1 - No Brakes!*FIXED*

Had a strange experience today when returning home from a short trip of around 20miles.

Approaching a roundabout I touched m,y brakes to start slowing down and my pedal went down to the floor. Pumped it a couple of times and was only doing around 15mph as I glided gracefully into an empty roundabout.
Exiting and with less than mile to reach home, I drove very slowly - annoying all the holiday makers and used the handbrake to slow and stop.
I kept tentatively dabbing at the foot brake but still very pumpable. About three hundred yards from home I had to brake for an idiot 'L' on moped and automatically hit the footbrake; lo and behold the darned thing is working normally.
I checked under the bonnet only to see what my brake fluid res was like and it's OK. Nipping down to the garage on Tuesday to see the lads and get it sorted.
Anyone else been subjected to the same phenomenon?
Jonesy is offline  
  5 Lastest Threads by Jonesy
Thread Forum Last Poster Replies Views Last Post
Scenic '02 headrests Interiors Jonesy 2 1026 12th October 2009 11:33 AM
Rear window stickers Bodywork aviator 13 2138 11th March 2009 04:05 PM
Scenic I - Bits & pieces Cars & motoring ottoman 2 832 25th January 2009 12:25 PM
Renault Clio 1 - No Brakes!*FIXED* Clio Mclarenfan 9 4571 3rd May 2008 03:29 PM
Change of Tranny fluid Clio I Engines Jonesy 7 1355 10th September 2007 12:41 PM
For the best viewing experience please update your browser to Google Chrome