Renault Forums :: Independent Renault forum - View Single Post - Megane II and me have just been on an AA Truck!! WOW! NOT!!

View Single Post
post #1 of (permalink) Old 3rd April 2006 Thread Starter
Diamond member
Join Date: Dec 2005
Posts: 114
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 2 Posts
Unhappy Megane II and me have just been on an AA Truck!! WOW! NOT!!

Evening people!
What can I say!! interesting evening, just been dropped off at home by the AA about 20min ago.

My poor Megane smells like a bonfire!

Was driving home from my girlfriends house when "power steering fault" came on the screen. The service light came on and the door unlocked. I thought ok, enough time to get home.

Carried on, PAS not effected at all.
2min later, that went off and 30sec after that the ABS and airbag light came on along the with service light again, door unlocked again, etc etc. that stayed on for 10 sec ish.

After that the faults kept flashing on and off really fast, the locks were going mad.

I pulled over, as I stopped, "Electrical Fault" came on the screen. All the lights came on, the wipers started going at full pelt, the windows went down, sunroof opened. Every light on the dash came on as well.

I tried to turn the engine off but nothing happened!!!!!!! It kept going!!! I tried again a few times and then the engine fan came on at full pelt as well.

I got straight on the blower to the AA who didn't advise me much, just that they were on there way. I asked for advice because the engine would not turn off.

So I am there sitting in my car with the full works going. after about 10min of waiting the radio and the climate control went off, 30sec later it came back on and the climate control was blowing full power! the car filled with smoke!

I waked it into 6th and stalled it to cut the engine out.
Got out n ran up the hill!!!!

Electronics still going mad and the car not responding to anything. If that couldn't top it all off the alarm started going and the horn started going and stuck on!!!!

AA Arrive 15min later, he opens the bonnet and is greeted by a large cloud of smoke!!

There was no sign of a fire, but he thinks there may have been one.

Couldn't find out what was up with it, so he disconnected the battery and towed me home!!

Now my poor Megane is sat in the drive and I don't have a clue what to do with her or where to start.

Seems like a Renault job to me, what do you guys think?

Advice needed please.

Anyone else experienced this before?



2002 1.9 DCI Megane II
92k on the clock

PS: Does anyone know any companys that will give me tempory insurance on another car?
I still have my old SEAT Ibiza, i just need to insure it until the Megane is fixed.
It is not covered under my Megane Policy.
I am just after paying for 3 weeks insurance or so.

Currently in chrisash32's garage:
2002 Renault Megane Sport II 1.9dCi
chrisash32 is offline  
  5 Lastest Threads by chrisash32
Thread Forum Last Poster Replies Views Last Post
Its Bye Bye Renault i am affraid :-( Cars & motoring vass20 61 11307 7th January 2007 10:27 PM
Megane II - Electronics - Keyless Problems Electronics 4 4263 28th August 2006 05:56 PM
Poll For North West Meet Regional activity superbiatch 3 1902 14th August 2006 02:12 PM
Megane II and me have just been on an AA Truck!!... Electronics chrisash32 24 5075 3rd April 2006 12:23 AM
Renault Laguna II - Phase 1 - Engines - Average... Laguna NickTT 373 163551 13th January 2006 07:27 AM
For the best viewing experience please update your browser to Google Chrome