Renault Forums :: Independent Renault forum - View Single Post - Laguna Electronics

View Single Post
post #1 of (permalink) Old 14th May 2008 Thread Starter
Junior Member
Join Date: May 2008
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Laguna Electronics

Hi, 1st post on here so here goes. I bought my 04 Laguna II 2.2Dci about 6 months ago. after 2 weeks I decided to get the ECU remapped and fit a K&N panel filter, this then Dyno'd at just under 190 Bhp, not bad for a family diesel hatchback. anyway, so far, 6 months of happy motoring, until yesterday!!! When inserting the card into the ignition slot the dashboard lights all do thier usual thing and light up then go out, BUT then ABS, TRACTION CONTROL AND SERV lights flash 3 times. This in itself seems to cause no problem but my stereo keeps cutting out too, usually when I use something else in the car like the indicators, the lights or taking my foot off the gas. again nothing major but is there any chance these things are connected??? and if so are they going to cause further problems?? I've had nothing but good things to say to anyone about my car to this point but I have read lots of bad things about the laguna's electrics and now I'm getting worried.
Currently in atticboy's garage:
2004 Laguna 2.2 Dci Extreme
atticboy is offline  
  5 Lastest Threads by atticboy
Thread Forum Last Poster Replies Views Last Post
Laguna Electronics Electronics madnoel10 1 815 14th May 2008 12:35 AM
For the best viewing experience please update your browser to Google Chrome