Renault Forums :: Independent Renault forum - View Single Post - Horn fix

Thread: Horn fix
View Single Post
post #1 of (permalink) Old 16th May 2008 Thread Starter
davesss's Avatar
Join Date: Sep 2005
Posts: 4,838
Nominated 0 Times in 2 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 145 Times in 126 Posts
Horn fix

I discovered my horn was not working yesterday, how long for I don't know.

I first checked the fuse in the panel at the right end of the dash which is covered when the door is opened but that was OK.

99% of the time when your horn stops working it is caused by oxidization or corrosion of the connections to the horn, that's what was wrong with mine.

To access the horns you take off the louvered plastic splash panel behind the bumper on the left side. This is secured by one 10mm bolt, one Phillips screw and one plastic retaining plug, remove these and the panel will fold down.

Shown in Photo 2.

You can just see the lower of the 2 horns, this horn takes the feed from your horn button and is relayed to the top horn which you can hardly see or reach.

White plug shown in the Photo 1

Release the white plug from the bottom horn after pulling out the spring clip, (don't lose it) then work the plug on and off the horn connections a few times to clean it testing to see if the horn works, keep moving the plug on and off till it does.

To reconnect the plug insert the spring clip on the plug and push it back on until you hear a click.

If you need to access the top horn the front bumper will have to be removed, full instructions with photos in the link below..............
Attached Thumbnails
Click image for larger version

Name:	Horn location.jpg
Views:	169
Size:	56.7 KB
ID:	5784   Click image for larger version

Name:	Horn access.jpg
Views:	156
Size:	62.6 KB
ID:	5785  

A problem well stated is a problem half solved !
Currently in davesss's garage:
2002 Laguna Sports Tourer 1.8 Dynamique Moondust VF1KGOB, Fiat Siecento Micheal Schumaker, Kawasaki KLE M/Cycle and a cheap Mountain Bike.

Last edited by davesss; 16th May 2008 at 01:14 PM.
davesss is offline  
  5 Lastest Threads by davesss
Thread Forum Last Poster Replies Views Last Post
Fast Car ! General Chat madnoel10 5 1202 3rd October 2012 04:20 PM
Lag 11 1.9 diesel tubo problem Other makes faram21 7 4232 16th April 2012 11:03 AM
For the best viewing experience please update your browser to Google Chrome