Renault Forums :: Independent Renault forum - View Single Post - speedo / radio/temp poor ilumination

View Single Post
post #1 of (permalink) Old 17th May 2008 Thread Starter
Junior Member
perry081064's Avatar
Join Date: Mar 2008
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy speedo / radio/temp poor ilumination

sorry if i posted in wrong area, please move if i have

i have a problem with my laguna 1 phase 2 1.6 alize
(2000 w plate ).

The clock / radio / temp panel is well lit up in the daytime, however if i turn on the sidelights or headlights in dull weather, the panel is barely lit ( ie. you realy need to concentrate to see what radio station you are on.)
...if you then turn the lights off, full bright ilumation again.

not sure if the speedo panel has the same fualt but that isnt really that bright at night iether.

it doesnt seem to be a battery drain becouse indicator panel lights or anything else in the car doesnt dim when the car requires any lighting/ more juice.

as this is my first lag im not sure how bright they are supposed to be at night but surely it should be better than barely readable ?

any help / advise please

Currently in perry081064's garage:
2000 laguna 1.6 16v
perry081064 is offline  
  5 Lastest Threads by perry081064
Thread Forum Last Poster Replies Views Last Post
head unit question Electronics mojolicious 1 564 26th May 2008 11:42 AM
speedo / radio/temp poor ilumination Electronics perry081064 2 799 17th May 2008 03:39 PM
For the best viewing experience please update your browser to Google Chrome