Renault Forums :: Independent Renault forum - View Single Post - Clio mk1 electronics problem

View Single Post
post #1 of (permalink) Old 19th May 2008 Thread Starter
Join Date: May 2008
Posts: 74
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Cool Clio mk1 electronics problem

Hey, not been here long was wondering if anyone could help.

I recently had my car serviced and since then my radio cuts out whenever I turn my lights on, flash someone (with the headlights, my shirt always stays on) and the central locking doesn't work properly, it thinks it locks but the pegs don't go down all the way in the doors so it is still open-able.

Any help greatly appreciated.



Edit: Also its a 1.2 RL Penashe (but spelt right). Just rememberd the lights also dim when ever I break so I'm leaning towards a battery/ alternator failing
Currently in jme's garage:
1997 Clio MK 1 Panache 1.2i (The Beast)

Last edited by jme; 19th May 2008 at 11:29 AM. Reason: Add more info
jme is offline  
  5 Lastest Threads by jme
Thread Forum Last Poster Replies Views Last Post
What utter Idiots Cars & motoring jme 17 2150 1st June 2008 05:38 PM
Model/ Trim Level Interiors jme 24 3053 28th May 2008 12:16 PM
Door Card Removal Interiors VelSatisfied 4 1408 22nd May 2008 09:01 PM
RedEx Engines rjboodell 4 1374 22nd May 2008 08:31 AM
Clio mk1 electronics problem Electronics dave_mezza2006 11 1946 19th May 2008 11:16 AM
For the best viewing experience please update your browser to Google Chrome