Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II - Phase 1 - Engines - Spark Plug Type - 2.0 IDE Laguna 2002

View Single Post
post #25 of (permalink) Old 6th April 2006
ide man
Diamond member
Join Date: Mar 2006
Posts: 181
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

Hi Duran

I have seen this problem on a lot of ide engines generally its faulty plugs or the wrong plugs for the vehicle check them they should be changed I would say every 10,000 miles I would say and do not leave 17,000 miles between serviceing or you will be asking for trouble .
But some injector cleaner in as this engine can be known for carboning up . When your tank is empty bob in the req amount and fill . I feel this may help but first change plugs

Make sure you get the right ones the ones for the ide engine and renault only plugs other wise you will get a misfire under load .

With the mileage you have on your vehicle I would take it to renault and ask for the plugs to be changed this may cost you 60 but they should have it on the computer and also if it is anything serious you should get a warranty payment as I believe your vehicle is just over three years old but with that mileage they should still pay depending on whats wrong with it .

Before you take it in check your airfilter if it is mucky that could be your problem .
Or the fuel pressure reg none of these are an expensive job .

Anyway what are you doing 120 mph for

Hope this helps ide man
Currently in ide man's garage:
03 laguna initiale 2ltr ide
ide man is offline  
For the best viewing experience please update your browser to Google Chrome