Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 2 - 1.8 16v Throttle Problem*FIXED*

View Single Post
post #32 of (permalink) Old 5th June 2008
Junior Member
Bubs's Avatar
Join Date: Mar 2008
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
OK just an update but hopefully a useful one for others with this problem.
We waited for a nice dry day and repeated the ecu clean leaving the open ends of the connectors in the sun for a few hours, replaced and all was well for 24 hrs then the fault re-occurred.
We have now removed and cleaned the throttle body (it was just a bit black inside, no 'bits' to speak of) and the car if anything is now worse!
Managed to get into our local garage who had the car for 2 days and couldn't get the fault to re-occur but cleared the fault and all was well for 3 days before backcame the fault (they said that would probably happen) took the car back to them today with the fault warning showing and the car in 'limp home' and they put it straight onto their diagnostic machine, their experienced mechanic is 98% sure that this is an ECU fault as he was able to send the correct signal to the throttle and get the throttle to respond correctly, as we were watching ther display he was telling us that the 2 signals did not correspond (was above my head by now!) having switched off and cleared the fault we could see the correct 'box' shaped signal.
Options at the moment are
repalcement ECU from Renault 700 odd quid
replacement reprogrammed ECU about 200
send off have tested and repaired my ECU about 180 ish
still not good but not the 700 that Renault want!
Watch this space.
Currently in Bubs's garage:
2002 Laguna 1.6 Expression
Bubs is offline  
For the best viewing experience please update your browser to Google Chrome