Renault Forums :: Independent Renault forum - View Single Post - laguna 2 Instrument clocks Failure

View Single Post
post #1 of (permalink) Old 23rd June 2008 Thread Starter
A1 Rick xbox360
Junior Member
A1 Rick xbox360's Avatar
Join Date: Feb 2008
Posts: 14
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
laguna 2 Instrument clocks Failure

hi everyone.
since work is crap right now, so i cant exchange cars.
am stuck with the worse car i`ve ever owned.

so many faults, have been fixed. and this is a 51 reg car so worth sod all
i`ve spent n 3k since i bought it 2 years ago

right now my Instrument `clocks` are in Failure.
the handbrake light has come on, but the speedo does not work any longer.
it started intermittently
now its complete failure
everything else works OK (touch wood)

but no speedo, so no trip computer etc

any ideas??

prob a multi plug at the rear of the Instrument panel
i guess its not a diy job

am just wondering if there is a fuse or relay that's gone?

am currently using my speed-cam detector as a speedo
Currently in A1 Rick xbox360's garage:
Aprilia RSV Tuono 1000 gen 1 & 2001 Renault Laguna II 1.9dCi
A1 Rick xbox360 is offline  
  5 Lastest Threads by A1 Rick xbox360
Thread Forum Last Poster Replies Views Last Post
laguna 2 Instrument clocks Failure Electronics A1 Rick xbox360 4 925 23rd June 2008 07:11 PM
will not rev up/ accelerate Electronics A1 Rick xbox360 5 2529 4th February 2008 04:23 PM
For the best viewing experience please update your browser to Google Chrome