Renault Forums :: Independent Renault forum - View Single Post - TDC sensor issues

View Single Post
post #1 of (permalink) Old 28th June 2008 Thread Starter
slingshot's Avatar
Join Date: Jun 2008
Posts: 43
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
TDC sensor issues

i removed the TDC from my Clio the other day and cleaned it (was rather unclean looking).
Anyway, refitted it and the car started fine. The tried to start it again shortly afterwards and nothing happened, not even a click (just all the dash lights coming on) !
I was sittin in the car on my drive on a slight hill and released the handbrake and tried to start it again and the engine started after a slight turn of the crank! I presume ive knocked the timing out? This has happened again several times since. Wont start, then i release handbrake and roll in gently and the engine starts when i turn the key. Should i get this looked at in a garage as its a bit silly having to do this 3 or 4 times a week. Should i have replaced the TDC sensor? And is the timing gonna be out?

Currently in slingshot's garage:
Clio II RN Grande
slingshot is offline  
  5 Lastest Threads by slingshot
Thread Forum Last Poster Replies Views Last Post
Clio - Noises from front wheels when turning... Wheels & tyres slingshot 8 2316 28th April 2011 09:21 AM
Clio Mk2 poor starting final questions Engines slingshot 15 3057 29th April 2009 07:36 PM
Buying a Clio MkII TDC crank sensor ??? Engines slingshot 8 7501 28th April 2009 03:14 PM
Needing a Clio Mk II TDC Sensor.... Welcome to RenaultForums slingshot 0 988 1st April 2009 09:15 AM
Window washer nozzle leaks / fault Bodywork madnoel10 4 2494 11th December 2008 07:16 PM
For the best viewing experience please update your browser to Google Chrome