Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2 - Uprating ICE

View Single Post
post #13 of (permalink) Old 8th July 2008
Platinum member
Mikey's Avatar
Join Date: Jan 2007
Posts: 1,184
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 4
Thanks: 0
Thanked 2 Times in 2 Posts
I'm gonna go for other, just because that's what I have!

I like my Sony products, I have a Sony Xplod HU which has a USB for MP3 player and a Ipod connection will aslo play pretty much any audio format you care to throw at it, MP3 WMA ATRAC ect. I have a sony USB 1 gig mp3 that plugs straight in (displays song title album info on HU too) and also a Sony 10 disc changer. Can't fault them realy, the second sony HU I've had, previous to that was a Kenwood. Couldn't fault that either mind but I find the sonys gave a clearer crisper sound. Also the Sony HU has the option of connecting to the stalk controls if I ever buy the lead!

I have a mish mash of speakers, Kenwood components, Sony mids and JBL 6x9's and Sub. All are pretty good and get the music pumping
The sub is run by a 600 watt 2ch Apline amp bridged, and the 6x9 run by a 350 watt 2ch Kenwood amp. Could do with another for the mids and components as they are currently run by the HU, but that gives out an impressive 4x54 watts.

It's totaly up to you mate what you get. If you want all the stuff from the same manufacturer go fot it. Or you can do what I did and build it up over time, but you tend to get what you can afford at the time and different make bits n bobs.

If I had to choose over Kenwood & Alpine I'd prob go with Alpine as I found my Kenwood a bit weird sounding, can't quite put my finger on it but not as good as sony. Freinds of mine have alpine HU's and swear by them. I also highly rate Pioneer speakers, had mids and 6x9's and they sounded great, only reason I don't have them now is cos they got nicked with one of my old cars
Currently in Mikey's garage:
1996 Mazda MX-3 V6, a 2002 1.2 8v Fiat Punto active (the Wife's!) and a 1998 Suzuki GN 125. Used to own a 2002 Laguna II Dynamique 1.8 16V (Now Sold yey!)

Last edited by Mikey; 8th July 2008 at 03:35 PM.
Mikey is offline  
For the best viewing experience please update your browser to Google Chrome