Renault Forums :: Independent Renault forum - View Single Post - Tyre Pressure Mon. Sys. Fault, receiver!!! HELP!

View Single Post
post #4 of (permalink) Old 8th July 2008
Diamond member
Eeeps's Avatar
Join Date: Oct 2006
Posts: 447
Nominated 0 Times in 1 Post
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 28 Times in 27 Posts
Originally Posted by smitd004 View Post
Hi there,

Thanks for the reply, i've found where the receiver SHOULD be, theres just a patch where it was!! I'm assuming it fell off when going through a flood yesterday. They were pretty bad, my car actually caught a fish in the wheel arches! Ren UK want 110 quid for the receiver. I understand that lots of people on these forums have had their system shut off. Well, (I dont know if this is against the rules??) does anyone fancy selling their redundant receiver or does anyone know where i might find one?

Many Thanks
The fixings for the receiver are quite poor. A couple of clips if I remember.

The receiver is not coded in anyway so get one from a breakers. I wouldn't expect to pay more than £30.
Make sure you also take the clips.

What state is the wiring loom in? It might be worth replacing this to. As far as I know it goes from the receiver unit backwards to the near side rear wheel arch. There is a connector block inside the wheel arch (of all places!)

Currently in Eeeps's garage:
2011 Clio III dCi 88 Dynamique and 2016 CitroŽn Grand C4 Picasso Exclusive+ EAT6 2.0 BlueHDi
Eeeps is offline  
For the best viewing experience please update your browser to Google Chrome