Renault Forums :: Independent Renault forum - View Single Post - Clio Dynamique - Indicator Problem.

View Single Post
post #1 of (permalink) Old 9th July 2008 Thread Starter
SAM-1990's Avatar
Join Date: May 2008
Posts: 31
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Clio Dynamique - Indicator Problem.

Sorry to bring this up again. but I really need this problem fixing by tommorow as I am driving a long distance!

My passenger side indicator is not working! There is NO notification on the dash of it being dead, no double click or flash, its as if it was never there. Although the driver side one works perfectly.

However, also when i turn on my hazards on open my car ( both sides flash) no light flashs either!

This means, that the indicator stalk, is not faultly as with opening the car the light is also inactive.

I have swapped both lights over, the "broken" panel to the working side.

And then it works! This also means that the panel is not faulty! as it works in the other side connected to the driver side wiring!


Can anyone help me sort this out as I need it fixing ASAP!

Thank you all so much!


ALSO When im driving and dry to turn the indiactor, a weird whining sounds sometimes occours and gently fades out. Just incase that helps you figure out the problem.
Currently in SAM-1990's garage:
Black Renault Clio Dynamique Black (2003)

Last edited by SAM-1990; 9th July 2008 at 07:53 PM.
SAM-1990 is offline  
  5 Lastest Threads by SAM-1990
Thread Forum Last Poster Replies Views Last Post
Renault Clio - 3rd Gear Issues Engines madnoel10 6 1382 22nd January 2009 04:55 PM
Renault Clio 03 Dynamique Problems Engines madnoel10 1 1110 30th September 2008 05:46 PM
Lighting wire, faultly? Messing with lights and... Electronics MattGwilson 25 5772 13th August 2008 09:36 PM
Renault clio 2003, ECU Problem? Electronics Ralph 10 3740 3rd August 2008 06:38 PM
Clio Dynamique - Indicator Problem. Electronics Lagdti 3 1947 9th July 2008 07:37 PM
For the best viewing experience please update your browser to Google Chrome