Renault Forums :: Independent Renault forum - View Single Post - ICE - How to run wires from engine bay

View Single Post
post #15 of (permalink) Old 8th August 2008
laguna steve
Diamond member
laguna steve's Avatar
Join Date: Jan 2007
Posts: 152
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 1 Time in 1 Post
Originally Posted by Amrik View Post
Hi Steve

I have purchased the following wiring kit:-


Hi Amrik

Just to clarify things, that particular wiring kit is usable if all you running is 1amp in the boot to power 1 sub,
Having witnessed several cars going up in smoke over the years because the wiring was not adequate and they were not earthed or fused in the correct manner, I even refused to touch a lads car until he removed all of his own wiring as it was a health hazard........

I would still, go out and buy,,,
6 meters of 4 gauge power cable
6 meters of 4 gauge earth cable
The remote cable (the thin blue one) is OK if you’ve got the 1amp

If this is split to power 2 or 3 amps the 12 volts is reduced along the line, sounds funny but I have experienced this my self after having a system tested by the armor auto lads and we had to run a cable from the battery to a relay so a true 12v was passed down the line to all 4 amps in the boot

The RCA,s again OK but I would go out and get some decent leads rather then use the one supplied in the pack.

Food for thought, if I can help any further just halla

Currently in laguna steve's garage:
2001 Renault Laguna 2 V6 + BMW E39 525 M Sport + Skyline R34 GTRR
laguna steve is offline  
For the best viewing experience please update your browser to Google Chrome